Polylang

In order to make the post translations to be synced you need to do just two simple steps.

  1. Make sure that you have a PRO version of Polylang plugin installed. Actually you do not need to install it on all the sites, only on those you are going to crosspost to (this step is optional if you’re using a WordPress Multisite).
  2. Install and activate a free add-on for Polylang, you can download it below. Please pay attention and use a correct version of the add-on.

In case you’re using a multisite version of the plugin:

Download Simple Multisite Crossposting – Polylang 1.0

For a regular version of the plugin:

Download Simple WP Crossposting – Polylang 1.0

It also works with WooCommerce, though you may also need Polylang for WooCommerce.

Need more help?